<!DOCTYPE html><html lang="en"><head><title>ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to Secure Counsel Before Important Deadline in Securities Class Action - CEL</title><script type="application/javascript" id="polyfill-script">if(!Array.prototype.includes||!(window.Object && window.Object.assign)||!window.Promise||!window.Symbol||!window.fetch){document.write('<script type="application/javascript" src="/pf/dist/engine/polyfill.js?d=277" defer=""><\/script>')}</script><script id="fusion-engine-react-script" type="application/javascript" src="/pf/dist/engine/react.js?d=277" defer=""></script><script id="fusion-engine-combinations-script" type="application/javascript" src="/pf/dist/components/combinations/default.js?d=277" defer=""></script><link id="fusion-template-styles" rel="stylesheet" type="text/css"/><link rel="stylesheet" href="https://gray-wsaw-prod.cdn.arcpublishing.com/pf/resources/dist/__global/css/main.css?d=277"/><link rel="stylesheet" href="https://gray-wsaw-prod.cdn.arcpublishing.com/pf/resources/dist/wsaw/css/main.css?d=277"/><link href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/5.15.4/css/all.min.css" rel="stylesheet"/><link rel="icon" type="image/x-icon" href="/pf/resources/images/favicons/wsaw/favicon.ico?d=277"/><link rel="amphtml" href="https://www.wsaw.com/prnewswire/2022/07/29/rosen-highly-recognized-law-firm-encourages-celsius-investors-with-losses-excess-100k-secure-counsel-before-important-deadline-securities-class-action-cel/?outputType=amp"/><meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"/><meta http-equiv="X-UA-Compatible" content="IE=edge"/><meta charSet="UTF-8"/><meta name="distribution" content="global"/><meta name="rating" content="general"/><meta name="copyright" content="Copyright (c) 2022 "/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta name="apple-itunes-app" content="app-id=420942233"/><meta name="google-play-app" content="app-id=com.graytv.android.wsawnews"/><meta name="burst" content="wsaw"/><meta property="og:url" content="https://www.wsaw.com/prnewswire/2022/07/29/rosen-highly-recognized-law-firm-encourages-celsius-investors-with-losses-excess-100k-secure-counsel-before-important-deadline-securities-class-action-cel/"/><link rel="canonical" href="https://www.wsaw.com/prnewswire/2022/07/29/rosen-highly-recognized-law-firm-encourages-celsius-investors-with-losses-excess-100k-secure-counsel-before-important-deadline-securities-class-action-cel/"/><meta name="robots" content="noindex"/><meta name="googlebot" content="noindex"/><meta name="googlebot-news" content="noindex"/><meta property="fb:admins" content="644426401"/><meta property="fb:app_id" content="109192188374"/><meta property="fb:pages" content="49134238659"/><meta property="article:publisher" content="https://www.facebook.com/NewsChannel7/"/><meta name="keywords" content=""/><meta name="news_keywords" content=""/><meta itemProp="image" property="og:image" content="https://www.wsaw.com/pf/resources/images/logo-icons/wsaw.svg?d=277"/><meta name="twitter:image" content="https://www.wsaw.com/pf/resources/images/logo-icons/wsaw.svg?d=277"/><meta property="og:site_name" content="https://www.wsaw.com"/><meta property="og:title" content="ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to Secure Counsel Before Important Deadline in Securities Class Action - CEL"/><meta name="twitter:title" content="ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to Secure Counsel Before Important Deadline in Securities Class Action - CEL"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:site" content="@wsaw"/><meta name="twitter:creator" content="@wsaw"/><script type="application/ld+json" data-schema="NewsMediaOrganization">{
  "name": "WSAW",
  "url": "https://www.wsaw.com",
  "logo": {
    "@type": "ImageObject",
    "url": "https://www.wsaw.com/pf/resources/images/logo-off-site/wsaw.png?d=277"
  },
  "@type": "NewsMediaOrganization",
  "sameAs": [
    "https://www.facebook.com/NewsChannel7/",
    "https://www.instagram.com/newschannel7_wsaw/",
    "https://www.twitter.com/wsaw/"
  ],
  "@context": "http://schema.org"
}</script><script type="application/ld+json" data-schema="NewsArticle">{
  "name": "ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to...",
  "url": "https://www.wsaw.com/prnewswire/2022/07/29/rosen-highly-recognized-law-firm-encourages-celsius-investors-with-losses-excess-100k-secure-counsel-before-important-deadline-securities-class-action-cel/",
  "image": "https://www.wsaw.com/pf/resources/images/logo-off-site/wsaw.png?d=277",
  "@type": "NewsArticle",
  "@context": "http://schema.org",
  "keywords": [],
  "headline": "ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to Secure Counsel Before Important Deadline in Securities Class Action - CEL",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.wsaw.com/prnewswire/2022/07/29/rosen-highly-recognized-law-firm-encourages-celsius-investors-with-losses-excess-100k-secure-counsel-before-important-deadline-securities-class-action-cel/"
  },
  "author": {
    "@type": "Person",
    "name": "PRNewswire"
  },
  "publisher": {
    "name": "WSAW",
    "url": "https://www.wsaw.com",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.wsaw.com/pf/resources/images/logo-off-site/wsaw.png?d=277"
    },
    "@type": "NewsMediaOrganization"
  },
  "datePublished": "2022-07-29T23:15:00Z",
  "datemodified": "2022-07-29T23:15:00Z"
}</script><script crossorigin="anonymous" src="https://polyfill.io/v3/polyfill.min.js?features=NodeList.prototype.forEach%2CArray.prototype.forEach%2CSymbol.hasInstance%2Ces6%2CIntl%2ClocalStorage%2CDate.prototype.toISOString%2CDate.now%2Cdefault%2CObject.entries%2CObject.fromEntries%2CArray.prototype.entries"></script><script type="text/javascript" src="https://gray-wsaw-prod.cdn.arcpublishing.com/pf/resources/js/analytics/gtm.js?d=277"></script><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://reconditerespect.com/v2dpkStyB22xLAVKsB3fWsLZ0bdhXgxP--eGpcUoZJhAWkQrenZcpEoZzCg",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");;;;!(function(t,n,i,u,e,o){var a=n[i];function r(t){if(t){var u=(t.data||{})[i+"Call"];u&&n[i](u.command,u.version,function(n,i){t.source.postMessage({__uspapiReturn:{returnValue:n,success:i,callId:u.callId}},"*")})}}if((function c(){if(!window.frames[u]){var n=t.body;if(n){var i=t.createElement("iframe");i.style.display="none",i.name=u,n.appendChild(i)}else setTimeout(c,5)}})(),"function"!=typeof a){var s={getUSPData:function(n,i){return n!==1?i&&i(null,!1):i&&i({version:null,uspString:null},!1)}};a=n[i]=function(n,i,t){return s[n](i,t)},n.addEventListener?n.addEventListener("message",r,!1):n.attachEvent&&n.attachEvent("onmessage",r)}o=t.createElement(e),t=t.getElementsByTagName(e)[0],o.src="https://reconditerespect.com/v2hhhOtmBeU0ASxTff7l7GDrDEcgNkq4OkY-3RhjZaSCZCPnSkDYh4CSG9qu31fx_taL_ApDJkvE",t.parentNode.insertBefore(o,t)})(document,window,"__uspapi","__uspapiLocator","script");</script><script type="text/javascript">(function() {
  var purl = window.location.href;
  var url = '//ads.pubmatic.com/AdServer/js/pwt/161733/6819';
  var profileVersionId = '';
  if(purl.indexOf('pwtv=')>0){
      var regexp = /pwtv=(.*?)(&|$)/g
      var matches = regexp.exec(purl);
      if(matches.length >= 2 && matches[1].length > 0){
          profileVersionId = '/'+matches[1];
      }
  }
  var wtads = document.createElement('script');
  wtads.async = true;
  wtads.type = 'text/javascript';
  wtads.src = url+profileVersionId+'/pwt.js';
  var node = document.getElementsByTagName('script')[0];
  node.parentNode.insertBefore(wtads, node);
})();
</script><script type="text/javascript">!(function () {window.PianoESPConfig = {id: 431,};var e = document.createElement("script");e.setAttribute("id", "pnesplucidsdksel"),(e.type = "text/javascript"),(e.src = "https://api-esp.piano.io/public/sdk/v04/sdk.js?v="+((localStorage && localStorage.lucidsdkver) || "xxx")),(e.async = !0),document.getElementsByTagName("script")[0].parentNode.appendChild(e);})();</script><script type="text/javascript" src="/pf/resources/js/analytics/comscore.js?d=277"></script><script type="text/javascript">
          var gdmComscore = ns_.analytics;
          gdmComscore.PlatformApi.setPlatformAPI(gdmComscore.PlatformApi.PlatformApis.WebBrowser)
          gdmComscore.configuration.addClient(new gdmComscore.configuration.PublisherConfiguration({'publisherId':"10477191"}))
          gdmComscore.configuration.setUsagePropertiesAutoUpdateMode(gdmComscore.configuration.UsagePropertiesAutoUpdateMode.FOREGROUND_AND_BACKGROUND);
          // gdmComscore.configuration.enableImplementationValidationMode();
          gdmComscore.start();
         </script><script type="text/javascript">
    var RCdataLayer = [
      {
        adTarget: "/wires/press-releases",
        authors: [ {
            _id:  null,
            name:  "PRNewswire",
            type:  "author"
          }],
        canonicalUrl: "https://www.wsaw.com/prnewswire/2022/07/29/rosen-highly-recognized-law-firm-encourages-celsius-investors-with-losses-excess-100k-secure-counsel-before-important-deadline-securities-class-action-cel/",
        contentId: "5QUJFWDQQJCN3E5US7J7CH47ZA",
        contentKewords: [ ],
        contentName: "ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to Secure Counsel Before Important Deadline in Securities Class Action - CEL",
        contentOwner: "gray",
        contentTags: [ ],
        contentType: "story",
        datePublished: "07/29/2022",
        distributorCategory: "wires",
        distributorMode: "reference_denormalized",
        distributorName: "PRNewswire",
        distributorReferenceId: "cc164599-a609-4ade-ad67-ab71070d59c1",
        distributorSubCategory: "prnewswire",
        hasVideo: false,
        metaDescription: null,
        outputType: "default",
        platformName: "PageBuilder Fusion - Arc Publishing",
        primarySection: {
          _id:  "/wires/press-releases",
          name:  "Press Releases",
          path:  "/wires/press-releases"
        },
        publishedDay: "29",
        publishedMonth: "07",
        publishedYear: "2022",
        stationName: "wsaw",
        subtype: null,
        timezoneOffset: gdmGoogleTagManager.getTimezoneOffset(),
        userId: null,
        userTimezoneTimestamp: (new Date()).toString(),
        userTimezone: Intl.DateTimeFormat().resolvedOptions().timeZone,
        userAgent: navigator.userAgent
      }
    ];
  </script><script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','RCdataLayer','GTM-M5QQ3JP');</script><script>
    (function() {
      var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
      _sf_async_config.uid = 39189;
      _sf_async_config.domain = "wsaw.com";
      _sf_async_config.useCanonical = true;
      _sf_async_config.useCanonicalDomain = true;
      _sf_async_config.authors = "PRNewswire";
      _sf_async_config.type = "story";
      _sf_async_config.sections = "/wires/press-releases";
      _sf_async_config.flickerControl = false;
    })();
  </script><script async="" data-integration="chartbeat" src="//static.chartbeat.com/js/chartbeat.js"></script><script async="" src="//static.chartbeat.com/js/chartbeat_mab.js"></script><div id="fusion-static-enter:bdbe3c49b0e14179-script-reference" style="display:none" data-fusion-component="bdbe3c49b0e14179-script-reference"></div><script defer="" data-integration="queryly" src="https://www.queryly.com/js/queryly.v4.min.js"></script><script>window.addEventListener('DOMContentLoaded', (event) => {
            queryly.init("bdbe3c49b0e14179", document.querySelectorAll("#fusion-app"));
          });</script><div id="fusion-static-exit:bdbe3c49b0e14179-script-reference" style="display:none" data-fusion-component="bdbe3c49b0e14179-script-reference"></div>
<script>(window.BOOMR_mq=window.BOOMR_mq||[]).push(["addVar",{"rua.upush":"false","rua.cpush":"true","rua.upre":"false","rua.cpre":"true","rua.uprl":"false","rua.cprl":"false","rua.cprf":"false","rua.trans":"SJ-d0b593df-d8e9-4d53-b01c-59994fdad974","rua.cook":"false","rua.ims":"false","rua.ufprl":"false","rua.cfprl":"false","rua.isuxp":"false","rua.texp":"norulematch"}]);</script>
                              <script>!function(e){var n="https://s.go-mpulse.net/boomerang/";if("False"=="True")e.BOOMR_config=e.BOOMR_config||{},e.BOOMR_config.PageParams=e.BOOMR_config.PageParams||{},e.BOOMR_config.PageParams.pci=!0,n="https://s2.go-mpulse.net/boomerang/";if(window.BOOMR_API_key="GE8WL-WLPKM-H3DAE-8HL27-MKCKB",function(){function e(){if(!o){var e=document.createElement("script");e.id="boomr-scr-as",e.src=window.BOOMR.url,e.async=!0,i.parentNode.appendChild(e),o=!0}}function t(e){o=!0;var n,t,a,r,d=document,O=window;if(window.BOOMR.snippetMethod=e?"if":"i",t=function(e,n){var t=d.createElement("script");t.id=n||"boomr-if-as",t.src=window.BOOMR.url,BOOMR_lstart=(new Date).getTime(),e=e||d.body,e.appendChild(t)},!window.addEventListener&&window.attachEvent&&navigator.userAgent.match(/MSIE [67]\./))return window.BOOMR.snippetMethod="s",void t(i.parentNode,"boomr-async");a=document.createElement("IFRAME"),a.src="about:blank",a.title="",a.role="presentation",a.loading="eager",r=(a.frameElement||a).style,r.width=0,r.height=0,r.border=0,r.display="none",i.parentNode.appendChild(a);try{O=a.contentWindow,d=O.document.open()}catch(_){n=document.domain,a.src="javascript:var d=document.open();d.domain='"+n+"';void(0);",O=a.contentWindow,d=O.document.open()}if(n)d._boomrl=function(){this.domain=n,t()},d.write("<bo"+"dy onload='document._boomrl();'>");else if(O._boomrl=function(){t()},O.addEventListener)O.addEventListener("load",O._boomrl,!1);else if(O.attachEvent)O.attachEvent("onload",O._boomrl);d.close()}function a(e){window.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(!window.BOOMR||!window.BOOMR.version&&!window.BOOMR.snippetExecuted){window.BOOMR=window.BOOMR||{},window.BOOMR.snippetStart=(new Date).getTime(),window.BOOMR.snippetExecuted=!0,window.BOOMR.snippetVersion=12,window.BOOMR.url=n+"GE8WL-WLPKM-H3DAE-8HL27-MKCKB";var i=document.currentScript||document.getElementsByTagName("script")[0],o=!1,r=document.createElement("link");if(r.relList&&"function"==typeof r.relList.supports&&r.relList.supports("preload")&&"as"in r)window.BOOMR.snippetMethod="p",r.href=window.BOOMR.url,r.rel="preload",r.as="script",r.addEventListener("load",e),r.addEventListener("error",function(){t(!0)}),setTimeout(function(){if(!o)t(!0)},3e3),BOOMR_lstart=(new Date).getTime(),i.parentNode.appendChild(r);else t(!1);if(window.addEventListener)window.addEventListener("load",a,!1);else if(window.attachEvent)window.attachEvent("onload",a)}}(),"".length>0)if(e&&"performance"in e&&e.performance&&"function"==typeof e.performance.setResourceTimingBufferSize)e.performance.setResourceTimingBufferSize();!function(){if(BOOMR=e.BOOMR||{},BOOMR.plugins=BOOMR.plugins||{},!BOOMR.plugins.AK){var n="true"=="true"?1:0,t="",a="eow65cvn37xs6yxeou4a-f-731ab4678-clientnsv4-s.akamaihd.net",i="false"=="true"?2:1,o={"ak.v":"32","ak.cp":"919522","ak.ai":parseInt("584964",10),"ak.ol":"0","ak.cr":16,"ak.ipv":4,"ak.proto":"http/1.1","ak.rid":"3057f942","ak.r":39889,"ak.a2":n,"ak.m":"dscr","ak.n":"ff","ak.bpcip":"35.173.238.0","ak.cport":33944,"ak.gh":"104.97.77.47","ak.quicv":"","ak.tlsv":"tls1.2","ak.0rtt":"","ak.csrc":"-","ak.acc":"reno","ak.t":"1659139384","ak.ak":"hOBiQwZUYzCg5VSAfCLimQ==4Z+ia/rrDiaWBb5HkT48ZJPyBHHjJ+rqDzz4Z0mEgldi9FVHm6l5WGSq/8XZwwrz187p/+omYQIFW4uRDkfQj086yQJGSEAnVfzt+8ET9OvossJSTB0wAZfo4VmMhMGNvkwM79W9fJ+fLDBEcOaDxHKcEsoSPm14i06LzK+Uj4gZremNETp38mjJxUVPDm9IgB1SCip3AxvEH/UcW2PUHoUhSTKjzfjxY18oWwaS66F5f6ylQr/z1zt62W5/rt/EHW+ZGHP8zdDmh53YVFk+FVQ+3OgjGKrlYMFmJ0FUKP8WsWEQrHKL5RKkyuRDTEzNzZW0x+OKsN12RYBeuUu2cc+3rb50VbK6QS1/prnFqPrgv/FXZ7c16iywIEIYBs8HDSHj5TUGRRk6ud6R+8cer5wJWfoNYicCTaWcHaEd+zg=","ak.pv":"11","ak.dpoabenc":"","ak.tf":i};if(""!==t)o["ak.ruds"]=t;var r={i:!1,av:function(n){var t="http.initiator";if(n&&(!n[t]||"spa_hard"===n[t]))o["ak.feo"]=void 0!==e.aFeoApplied?1:0,BOOMR.addVar(o)},rv:function(){var e=["ak.bpcip","ak.cport","ak.cr","ak.csrc","ak.gh","ak.ipv","ak.m","ak.n","ak.ol","ak.proto","ak.quicv","ak.tlsv","ak.0rtt","ak.r","ak.acc","ak.t","ak.tf"];BOOMR.removeVar(e)}};BOOMR.plugins.AK={akVars:o,akDNSPreFetchDomain:a,init:function(){if(!r.i){var e=BOOMR.subscribe;e("before_beacon",r.av,null,null),e("onbeacon",r.rv,null,null),r.i=!0}return this},is_complete:function(){return!0}}}}()}(window);</script></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fusion-app" class="fusion-app"><div id="article-right-rail-layout" class="includes-right-rail"><a class="skip-link sr-only sr-only-focusable px-3 text-body" href="#main">Skip to content</a><header id="main" class="masthead | w-100"><div class="sales-navigation | d-none w-100 bg-primary-branding d-lg-flex"><div class="container-xl"><div class="sales-nav-links | d-flex justify-content-start py-1"><div class="sales-nav-link |"><a class="text-nowrap text-reset text-decoration-none" href="/page/subscribe/">News and First Alert Weather App</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/community/calendar">Community Calendar</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/community/user-content/">Submit Photos</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/programming/schedule">Programming</a></div><div class="sales-nav-link | pl-3"><a class="text-nowrap text-reset text-decoration-none" href="/premier-places-to-work/">5 Premier Places to Work</a></div></div></div></div><div class="masthead | bg-primary-branding py-2" style="background-image:url(&#x27;/pf/resources/images/mastheads/backgrounds/wsaw.jpg?d=277&#x27;)"><div class="container-xl"><div class="d-flex justify-content-between w-100"><div class="logo flex-fill position-relative"><a class="logo-link" aria-label="Return to the Homepage" href="/"><div class="logo-inner position-absolute" style="background-image:url(&#x27;/pf/resources/images/mastheads/logos/wsaw.svg?d=277&#x27;)"></div></a></div></div></div></div></header><nav class="navigation | w-100"><div class="navigation | navigation-sticky-wrapper" style="min-height:undefinedpx"><div class="navbar | navbar-expand bg-primary-branding"><div class="container-xl position-relative"><a class="navbar-brand mr-1 d-none" aria-label="Return to the Homepage" href="/"><div class="brand-logo" style="background-image:url(&quot;/pf/resources/images/logo-icons/wsaw.svg?d=277&quot;)"></div></a><button aria-label="Expand Side Navigation Panel" class="side-drawer-toggle btn text-white" type="button"><span class="fas fa-bars"></span></button><ul class="navbar-links | navbar-nav mr-auto font-weight-bold"><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/news">News</a></li><li class="navbar-link | navbar-item d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/weather">Weather</a></li><li class="navbar-link | navbar-item d-none d-sm-flex d-md-flex d-lg-flex"><a class="nav-link text-white" href="/sports">Sports</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/livestream/">Livestream</a></li><li class="navbar-link | navbar-item d-none d-md-flex d-lg-flex"><a class="nav-link text-white" href="/page/subscribe/">Cord Cutters</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/community/daycare-dilemma">Daycare Dilemma</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/content/community/water-quality/">Water Quality</a></li><li class="navbar-link | navbar-item d-none d-lg-flex"><a class="nav-link text-white" href="/local-schools/">Local Schools</a></li></ul><label aria-label="Toggle search bar" class="queryly-nav-toggle pointer m-0 py-1 px-2" for="queryly_toggle"><i class="d-block fas fa-search"></i></label></div></div></div><div class="side-drawer-screen | fixed-top h-100 w-100 zindex-high"></div><div class="side-drawer | bg-primary-branding shadow-lg fixed-top h-100 w-100 overflow-y overflow-hide-scrollbar"><div class="side-drawer-container | d-none flex-column align-items-end h-100"><div class="side-drawer-cancel | w-100 p-2"><div class="d-flex flex-column align-items-end"><button aria-label="Close" class="btn btn-sm text-white"><i class="fas fa-times"></i></button></div></div><ul class="sections-list | list-unstyled w-100 pt-5 pb-4"><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news">News</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the News navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/agriculture">Agriculture</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/business">Business</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/community">Community</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/consumer">Consumer</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/crime">Crime</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/culture">Culture</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/education">Education</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics/election-results">Election Results</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/environment">Environment</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/extra">Extra</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/international">International</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/local">Local</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/national">National</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/politics">Politics</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/food/recipes">Recipes</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/state">State</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/traffic">Traffic</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/garden">Yard and Garden</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/weather">Weather</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Weather navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/radar">Interactive Radar</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/subscribe/">First Alert Weather App</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/closings">Closings</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/news/weather">Stories</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/maps">Maps</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/first-alert-weather-system/">First Alert Email Sign Up</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/weather/cams">SkyCams</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/weather-photos">Weather Photos</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/regional-ski-report">Ski Report</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://511wi.gov/#:Alerts" rel="noopener noreferrer" target="_blank">Road Conditions</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/snow-report">Snow Report</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/subscribe/">Download the Weather App</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/sports">Sports</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Sports navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/hello-my-name-is">Hello, My Name Is</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/hilight-zone">Hilight Zone</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/northwoods-league">Northwoods League</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/packers">Packers</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/podcasts">Podcasts</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/sports/scoreboard">Scores</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/upickem-college-basketball-bracket-contest/">UPick’EM Contest</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/your-town-stevens-point/">Your Town Stevens Point</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/content/community/water-quality">Water Quality</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/calendar">Community Calendar</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Community Calendar navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/gas-prices">Gas Prices</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/about-us/contact-us">Station</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Station navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/meet-the-team/">Station Bios</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/suscribe-to-enews/">e-News sign up</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/closed-captioning">Closed Captioning</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/about-us/contact-us">Contact Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://gray.tv/careers#currentopenings" rel="noopener noreferrer" target="_blank">Jobs at WSAW</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/order-a-copy-of-a-story-or-newscast-that-aired-on-newschannel-7">Order a Copy of a Story or Newscast That Aired on NewsChannel 7</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/sales">Sales</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/social">Social</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.cbs.com/" rel="noopener noreferrer" target="_blank">7.1 CBS</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.mynetworktv.com/" rel="noopener noreferrer" target="_blank">7.2 MyTV</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.fox.com/" rel="noopener noreferrer" target="_blank">7.3 Fox</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.yourcwtv.com/partners/wausau/" rel="noopener noreferrer" target="_blank">7.4 The CW</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/quest-network-comes-to-north-central-wisconsin">7.5 Quest TV</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.circleallaccess.com/" rel="noopener noreferrer" target="_blank">7.6 Circle</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.fox.com/" rel="noopener noreferrer" target="_blank">33.1 Fox</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.metv.com/" rel="noopener noreferrer" target="_blank">33.2 MeTV</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.moviestvnetwork.com/schedule/" rel="noopener noreferrer" target="_blank">33.3 MOVIES!</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://www.handitv.com/" rel="noopener noreferrer" target="_blank">33.4 Heroes &amp; Icons</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="https://starttv.com/" rel="noopener noreferrer" target="_blank">33.5 Start TV</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/news/investigation">7 Investigates</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/submit-a-news-tip">Submit a News Tip</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/subscribe/">Subscribe</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/buddycheck7/">Buddy Check 7</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/premier-places-to-work/">Premier Places to Work</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/politics/election-results">Election Results</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/community/user-content">Submit Photos and Videos</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.cpsc.gov/Recalls" rel="noopener noreferrer" target="_blank">Recalls</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/links/holiday-vacations/">Holiday Vacations</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/livestream/">What&#x27;s On?</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/programming/schedule">Programming</a><i class="expand-group | flex-fill text-right align-self-center pointer fas fa-caret-right" aria-expanded="false" aria-label="Expand the Programming navigation group" role="button"></i></div><div class="collapse"><ul class="links-group | list-unstyled font-weight-normal py-1"><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/livestream/">Livestream</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/subscribe/">Ways to Watch Us</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/programming/schedule">TV Listings</a></div></li><li class="link | child py-2 px-3"><div class="text-white h6 mb-0"><a class="" href="/page/watch-live-cbs-news">Watch CBS News</a></div></li></ul></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graytvlocal.com/market/north-central-wisconsin" rel="noopener noreferrer" target="_blank">Shop Local</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://wilottery.com/" rel="noopener noreferrer" target="_blank">Lottery</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/pets">Pet Project</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/covid-19-information/">COVID-19 Information</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/page/covid-19-map">COVID-19 Map</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/your-town/greater-wausau/">Your Town Wausau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.vuit.com/publishers/346/wsaw" rel="noopener noreferrer" target="_blank">Latest Newscasts</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.circleplus.com/" rel="noopener noreferrer" target="_blank">Circle - Country Music &amp; Lifestyle</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.graydc.com/" rel="noopener noreferrer" target="_blank">Gray DC Bureau</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="https://www.investigatetv.com/" rel="noopener noreferrer" target="_blank">Investigate TV</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/powernation/">PowerNation</a></div></li><li class="link | parent h5 mb-0"><div class="py-2 px-3 d-flex"><a class="" href="/wires/press-releases">Press Releases</a></div></li></ul><div class="social-bar | d-flex flex-row justify-content-center w-100 mt-auto p-3" style="bottom:0"><a aria-label="Visit WSAW on FACEBOOK" class="p-2" href="https://www.facebook.com/NewsChannel7" rel="noopener noreferrer" target="_blank"><i class="fab fa-facebook-f fa-2x"></i></a><a aria-label="Visit WSAW on INSTAGRAM" class="p-2" href="https://www.instagram.com/newschannel7_wsaw" rel="noopener noreferrer" target="_blank"><i class="fab fa-instagram fa-2x"></i></a><a aria-label="Visit WSAW on TWITTER" class="p-2" href="https://www.twitter.com/wsaw" rel="noopener noreferrer" target="_blank"><i class="fab fa-twitter fa-2x"></i></a><a aria-label="Visit WSAW on YOUTUBE" class="p-2" href="https://www.youtube.com/channel/UC-G6Uf34BVr_N14PA6uJodg" rel="noopener noreferrer" target="_blank"><i class="fab fa-youtube fa-2x"></i></a></div></div></div><div class="breaking-news-bar |"></div><div id="fusion-static-enter:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div><div id="htmlBox-f0fgruVYP9iIdU" class="html-box | w-100 p-3 mb-3"><div class="html-box-container" id="htmlBox-f0fgruVYP9iIdU-container"><div class="mb-3" /></div></div><div id="fusion-static-exit:f0fgruVYP9iIdU" style="display:none" data-fusion-component="f0fgruVYP9iIdU"></div></nav><section class="leaderboard | w-100"></section><div class="container-xl"><div class="row"><section class="top-wrapped | col-12"><div class="article-header article row mb-3"><div class="headlines |"><h1 class="headline | font-weight-bold col"><span>ROSEN, A HIGHLY RECOGNIZED LAW FIRM, Encourages Celsius Investors with Losses in Excess of $100K to Secure Counsel Before Important Deadline in Securities Class Action - CEL</span></h1></div><div class="date-time | col-12"><span class="date-time published-date-time font-italic d-inline-block">Published<!-- -->: <!-- -->Jul. 29, 2022 at 6:15 PM CDT</span><span class="px-2 d-inline">|</span><span class="date-time updated-date-time font-italic d-inline-block">Updated<!-- -->: <!-- -->48 minutes ago</span></div></div><div class="article-body | article w-100"><p class="text | article-text"><span class="xn-location">NEW YORK</span>, <span class="xn-chron">July 29, 2022</span> /PRNewswire/ --</p><figure class="image | figure article-image w-100 primary"><div class="img-wrapper figure-img"><img class="img-fluid mx-auto d-block" alt="Rosen Law Firm, P.A. Logo" height="148" src="https://gray-wsaw-prod.cdn.arcpublishing.com/resizer/eg7iag_si4M1ccdfLrH0Jl73LrA=/980x0/smart/filters:quality(85)/cloudfront-us-east-1.images.arcpublishing.com/gray/G5M5MO5M3MMRSJPCYAMWAGHPJA.jpg" width="980"/></div><figcaption class="figure-caption">Rosen Law Firm, P.A. Logo<span class="ml-2">(PRNewswire)</span></figcaption></figure><p class="text | article-text"><b>WHY:</b>Rosen Law Firm, a global investor rights law firm, reminds purchasers of Celsius Financial Products, including CEL Tokens, Earn Rewards high-interest accounts, and/or Celsius Loan products, between <span class="xn-chron">February 9, 2018</span>, and <span class="xn-chron">June 13, 2022</span>, inclusive (the "Class Period"), against Celsius Network LLC ("Celsius"), Celsius Lending LLC, Celsius KeyFi LLC (collectively, the "Celsius Entities") and its executives <span class="xn-person">Alexander Mashinsky</span>, Shlomi "Daniel" Leon, David Barse, and <span class="xn-person">Alan Jeffrey Carr</span> (together, "Defendants"), of the important<b> <span class="xn-chron">September 13, 2022</span> lead plaintiff deadline</b>.</p><p class="text | article-text"><b>SO WHAT:</b> If you purchased Celsius Financial Products, including CEL Tokens, Earn Rewards high-interest accounts, and/or Celsius Loan products you may be entitled to compensation without payment of any out of pocket fees or costs through a contingency fee arrangement.</p><p class="text | article-text"><b>WHAT TO DO NEXT: </b>To join the Celsius class action, go to <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3608032-1&amp;h=3094600068&amp;u=https%3A%2F%2Frosenlegal.com%2Fsubmit-form%2F%3Fcase_id%3D7586&amp;a=https%3A%2F%2Frosenlegal.com%2Fsubmit-form%2F%3Fcase_id%3D7586" rel="nofollow" target="_blank">https://rosenlegal.com/submit-form/?case_id=7586</a> or call <span class="xn-person">Phillip Kim, Esq.</span> toll-free at 866-767-3653 or email <a href="mailto:pkim@rosenlegal.com" rel="nofollow" target="_blank">pkim@rosenlegal.com</a> or <a href="mailto:cases@rosenlegal.com" rel="nofollow" target="_blank">cases@rosenlegal.com</a> for information on the class action. A class action lawsuit has already been filed. If you wish to serve as lead plaintiff, you must move the Court <b>no later than <span class="xn-chron">September 13, 2022</span></b>. A lead plaintiff is a representative party acting on behalf of other class members in directing the litigation.</p><p class="text | article-text"><b>WHY ROSEN LAW: </b>We encourage investors to select qualified counsel with a track record of success in leadership roles. Often, firms issuing notices do not have comparable experience, resources or any meaningful peer recognition. <b>Many of these firms do not actually handle securities class actions, but are merely middlemen that refer clients or partner with law firms that actually litigate the cases. </b>Be wise in selecting counsel. The Rosen Law Firm represents investors throughout the globe, concentrating its practice in securities class actions and shareholder derivative litigation. Rosen Law Firm has achieved the largest ever securities class action settlement against a Chinese Company. Rosen Law Firm was Ranked No. 1 by ISS Securities Class Action Services for number of securities class action settlements in 2017. The firm has been ranked in the top 4 each year since 2013 and has recovered hundreds of millions of dollars for investors. In 2019 alone the firm secured over <span class="xn-money">$438 million</span> for investors. In 2020, founding partner <span class="xn-person">Laurence Rosen</span> was named by law360 as a Titan of Plaintiffs' Bar. Many of the firm's attorneys have been recognized by Lawdragon and Super Lawyers.</p><p class="text | article-text"><b>DETAILS OF THE CASE: </b>According to the lawsuit, Defendants violated provisions of the Securities Act by selling non-exempt securities without registering it. The complaint alleges that Celsius and Individual Defendants violated provisions of the Securities Act by also participating in Celsius' failure to register the Celsius Financial Products. The complaint alleges that the Defendants violated provisions of the New Jersey Common Law by possessing the monetary value of Celsius Financial Products of inflated value which rightfully belongs to the Plaintiff and members of the Class.</p><p class="text | article-text">Also according to the lawsuit, Defendants violated provisions of the Exchange Act by carrying out a plan, scheme, and course of conduct that Celsius intended to and did deceive retail investors and thereby caused them to purchase Celsius Financial Products at artificially inflated prices; endorsed false statements they knew or recklessly should have known were material misleading, and they made untrue statements of material fact and omitted to state material facts necessary to make the statements made not misleading.</p><p class="text | article-text">To join the Celsius class action, go to <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3608032-1&amp;h=3094600068&amp;u=https%3A%2F%2Frosenlegal.com%2Fsubmit-form%2F%3Fcase_id%3D7586&amp;a=https%3A%2F%2Frosenlegal.com%2Fsubmit-form%2F%3Fcase_id%3D7586" rel="nofollow" target="_blank">https://rosenlegal.com/submit-form/?case_id=7586</a> or call <span class="xn-person">Phillip Kim, Esq.</span> toll-free at 866-767-3653 or email <a href="mailto:pkim@rosenlegal.com" rel="nofollow" target="_blank">pkim@rosenlegal.com</a> or <a href="mailto:cases@rosenlegal.com" rel="nofollow" target="_blank">cases@rosenlegal.com</a> for information on the class action.</p><p class="text | article-text">No Class Has Been Certified. Until a class is certified, you are not represented by counsel unless you retain one. You may select counsel of your choice. You may also remain an absent class member and do nothing at this point. An investor's ability to share in any potential future recovery is not dependent upon serving as lead plaintiff.</p><p class="text | article-text">Follow us for updates on LinkedIn: <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3608032-1&amp;h=432828243&amp;u=https%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fthe-rosen-law-firm&amp;a=https%3A%2F%2Fwww.linkedin.com%2Fcompany%2Fthe-rosen-law-firm" rel="nofollow" target="_blank">https://www.linkedin.com/company/the-rosen-law-firm</a>, on Twitter: <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3608032-1&amp;h=598222087&amp;u=https%3A%2F%2Ftwitter.com%2Frosen_firm&amp;a=https%3A%2F%2Ftwitter.com%2Frosen_firm" rel="nofollow" target="_blank">https://twitter.com/rosen_firm</a> or on Facebook: <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3608032-1&amp;h=3549768746&amp;u=https%3A%2F%2Fwww.facebook.com%2Frosenlawfirm%2F&amp;a=https%3A%2F%2Fwww.facebook.com%2Frosenlawfirm%2F" rel="nofollow" target="_blank">https://www.facebook.com/rosenlawfirm/</a>.</p><p class="text | article-text">Attorney Advertising. Prior results do not guarantee a similar outcome.</p><p class="text | article-text">Contact Information:</p><p class="text | article-text"><span class="xn-person">Laurence Rosen, Esq.</span><br/>      <span class="xn-person">Phillip Kim, Esq.</span><br/>      The Rosen Law Firm, P.A.<br/>      275 Madison Avenue, 40th Floor<br/>      <span class="xn-location">New York, NY</span> 10016<br/>      Tel: (212) 686-1060<br/>      Toll Free: (866) 767-3653<br/>      Fax: (212) 202-3827<br/>      <a href="mailto:lrosen@rosenlegal.com" rel="nofollow" target="_blank">lrosen@rosenlegal.com</a><br/>      <a href="mailto:pkim@rosenlegal.com" rel="nofollow" target="_blank">pkim@rosenlegal.com</a><br/>      <a href="mailto:cases@rosenlegal.com" rel="nofollow" target="_blank">cases@rosenlegal.com</a><br/>      <a href="https://c212.net/c/link/?t=0&amp;l=en&amp;o=3608032-1&amp;h=1313620683&amp;u=http%3A%2F%2Fwww.rosenlegal.com%2F&amp;a=www.rosenlegal.com" rel="nofollow" target="_blank">www.rosenlegal.com</a></p><p class="text | article-text">View original content to download multimedia:</p><div class="interstitial-link | border-0 mb-3"><div class="p-2"><div class="align-self-center"><h6 class="mb-0 font-weight-bold"><a class="" href="https://www.prnewswire.com/news-releases/rosen-a-highly-recognized-law-firm-encourages-celsius-investors-with-losses-in-excess-of-100k-to-secure-counsel-before-important-deadline-in-securities-class-action--cel-301596245.html">https://www.prnewswire.com/news-releases/rosen-a-highly-recognized-law-firm-encourages-celsius-investors-with-losses-in-excess-of-100k-to-secure-counsel-before-important-deadline-in-securities-class-action--cel-301596245.html</a></h6></div></div></div><p class="text | article-text">SOURCE  Rosen Law Firm, P.A.</p></div><div class="article-body | article w-100"><p class="text | article-text"><i>The above press release was provided courtesy of PRNewswire. The views, opinions and statements in the press release are not endorsed by Gray Media Group nor do they necessarily state or reflect those of Gray Media Group, Inc.</i></p></div></section><div class="col-12 d-flex flex-column flex-lg-row w-100"><div class="article-content-container | flex-lg-fill mr-lg-3"><section class="header | w-100"></section><section class="body | w-100"></section><section class="recommendations | w-100"></section></div><section class="right-rail | rail ml-lg-3 d-flex flex-column flex-lg-fill"></section></div><section class="bottom-wrapped | col-12"></section></div></div><footer class="footer | w-100"><div id="fusion-static-enter:footer-wsaw" style="display:none" data-fusion-component="footer-wsaw"></div><div class="footer | card bg-primary-branding mt-3 d-flex rounded-0 text-center text-sm-left zindex-highest"><div class="card-body"><div class="container"><div class="row"><div class="col"><div class="footer-links | row justify-content-start my-3"><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/news">News</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/weather">Weather</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/sports">Sports</a></div><div class="footer-link | col-6 col-sm-6 col-md-4 col-lg-3 align-self-center"><a class="text-white" href="/about-us/contact-us">Station</a></div></div></div><div class="col-12 col-sm-5 col-md-3 col-xl-2"><div class="footer-contacts | row justify-content-start my-3 small"><div class="col"><ul class="list-unstyled mb-0"><li class="footer-contact | font-weight-bold">WSAW</li><li class="footer-contact | footer-address">1114 Grand Ave.</li><li class="footer-contact | footer-city-state">Wausau, WI 54403</li><li class="footer-contact | footer-phone">(715) 845-4211</li></ul></div></div></div></div></div></div><div class="card-footer small pt-0"><div class="footer-links | d-flex flex-wrap justify-content-center text-center"><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/terms-of-service/" rel="noopener noreferrer" target="_blank">Terms of Service</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/privacy-policy" rel="noopener noreferrer" target="_blank">Privacy Policy</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/tv-profile/WSAW-TV" rel="noopener noreferrer" target="_blank">Public Inspection File</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://publicfiles.fcc.gov/api/manager/download/0a710a7a-8df2-2b52-40c8-0d3df49db898/ad2afe15-5178-4c09-84d0-bb93fdcda278.pdf" rel="noopener noreferrer" target="_blank">EEO Statement</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="https://webpubcontent.gray.tv/gdm/fcc/wsaw-fcc_applications.pdf" rel="noopener noreferrer" target="_blank">FCC Applications</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="mailto:web@wsaw.com" rel="noopener noreferrer" target="_blank">Public File: web@wsaw.com - (715) 845-4211</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/advertising/" rel="noopener noreferrer" target="_blank">Advertising</a></div><div class="footer-link | align-self-center px-3 pt-3"><a class="" href="/page/closed-captioning/" rel="noopener noreferrer" target="_blank">Closed Captioning/Audio Description</a></div><div id="ccpa-link" class="ccpa-dynamic-insertion-container d-flex align-self-center"></div></div></div><div class="footer-copyright | card-footer"><div class="font-weight-light small mx-auto text-center">A Gray Media Group, Inc. Station - <!-- -->© <!-- --> <!-- -->2002-2022 Gray Television, Inc.</div><div class="footer-corp-logo | w-100 mx-auto mt-2 mb-0"></div></div></div><div id="fusion-static-exit:footer-wsaw" style="display:none" data-fusion-component="footer-wsaw"></div></footer></div></div><script id="fusion-metadata" type="application/javascript">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</script></body></html>